Kawi2strokes.com Forum

Enthusiasts from around the world dedicated to the preservation and ritual flogging of the infamous Kawasaki 2-stroke Triples
It is currently Tue Feb 20, 2018 10:28 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 35 posts ]  Go to page Previous  1, 2, 3, 4
Author Message
PostPosted: Sun Mar 19, 2017 7:28 pm 
Moderator
User avatar

Joined: Wed Jun 08, 2011 5:34 pm
Posts: 2122
Location: Front Royal, VA
You do good work, my friend :thumbup: :thumbup: :thumbup: :thumbup:

_________________
I Love the Smell of Blue Marble in the Morning!!!
Tim Steele in Front Royal, VA
Home of the Phoenix Project
Stay in it when it comes on the pipe, no need to be scared...


Top
 Profile  
 
PostPosted: Sun Mar 19, 2017 7:35 pm 
User avatar

Joined: Wed Jun 08, 2011 11:34 pm
Posts: 8113
Location: North Central NC
It's definitely looking good, Carl. It'll be another thing for me to look forward to this May... seeing it running. :)

_________________
If it surges, that's normal, upshift.


Top
 Profile  
 
PostPosted: Sun Mar 19, 2017 7:55 pm 
Moderator
User avatar

Joined: Wed Jun 08, 2011 7:32 pm
Posts: 994
Location: Macon, GA
That looks great Carl! Can't wait to hear it spool up. 8-)

_________________
1972 Kawasaki H2 Mach IV (Candytone Blue), 1976 Suzuki GT750 (Maui Blue), 1984 Yamaha RZ350 (KRR- Yellow/Black), 1967 Yamaha YR1 (Red).


Top
 Profile  
 
PostPosted: Sun Mar 19, 2017 8:42 pm 
User avatar

Joined: Sun Jul 01, 2012 3:07 pm
Posts: 762
Location: Pollocksville, NC
Thanks guys, Tim got me motivated to get on my project hard, and I am glad I did because I have a long way to go! A lot closer after the last two weekends. I will surely bring it with the KZ mags on it. I have a lot to work out yet but after putting the body work on I think it looks pretty good with the mags, I just need to do some more cleanup. I have a couple of other bikes that will need some attention before the gap also.


Top
 Profile  
 
PostPosted: Mon Feb 12, 2018 11:02 pm 
User avatar

Joined: Sun Jul 01, 2012 3:07 pm
Posts: 762
Location: Pollocksville, NC
Well back to the drawing board on the throttle cable. The cable the Mr Turbo supplied is too short for the stock throttle tube so I had to make a new cable. Went to put it on this past weekend and the factory assembled end popped of the third time I wacked the throttle open... (not running of coarse just checking the slide travel) :(


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 35 posts ]  Go to page Previous  1, 2, 3, 4

All times are UTC - 5 hours


Who is online

Users browsing this forum: Bing [Bot]


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group